Laravel Spark 4.0 is Released

Laravel Spark v4.0 is now released and available to all license holders.

Spark 4.0 is a free upgrade and provides compatibility with Laravel 5.4. Also, Spark 4.0 applications are configured to use Laravel Mix and Webpack instead of Laravel Elixir.

If you have Spark installed through the CLI tool upgrading is as simple as running:

php artisan spark:update --major

For those with it installed through Composer you can update your composer.json file:

"laravel/spark": "~4.0"

After that, it’s best to consult the upgrade guide for getting your NPM packages up to date.